Back to overview
Degraded
Increased API latency
Oct 27 at 01:18pm EDT
Affected services
APIs
Dashboard
Resolved
Oct 27 at 02:39pm EDT
We've identified and deployed a fix. API latency has returned to normal levels.
Affected services
Created
Oct 27 at 01:18pm EDT
We're seeing increased latency across API endpoints. We're working to identify the root cause and will provide updates in due course.
Affected services