Back to overview
Degraded

Increased API latency

Sep 28 at 02:36pm EDT
Affected services
APIs
Dashboard

Resolved
Sep 28 at 03:21pm EDT

API latency has returned to normal levels and we're continuing to monitor closely.

Created
Sep 28 at 02:36pm EDT

We're seeing increased latency across API endpoints. We're working to identify the root cause and will provide updates in due course.