Back to overview
Resolved

Increased API latency

Jul 29, 2026 at 4:12pm UTC
Affected services
APIs

Resolved
Jul 29, 2026 at 4:27pm UTC

API latency has returned to normal levels.

Updated
Jul 29, 2026 at 4:22pm UTC

The infrastructure changes have been applied and APIs are returning to function. We're continuing to monitor latency.

Updated
Jul 29, 2026 at 4:14pm UTC

We've identified the cause of increased API latency and are applying infrastructure updates to fix the issue. We will encounter a short period of downtime whilst these updates take effect and we'll provide an update once in place.

Created
Jul 29, 2026 at 4:12pm UTC

We're seeing increased latency across all API endpoints. We'll provide further updates as we identify the root cause.